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ABSTRACT: Technologies recent advancements have made our lives smoother and quicker. The advancement in 
technology has resulted in an increase in road dangers. An IoT-based accident avoidance and warning technology is 
introduced in this paper to reduce casualties and save human lives. One of the most important problems that people 
want to overcome while buying a car. If the number of cars grows, traffic calming becomes a mess, resulting in 
collisions. Accidents may occur for a variety of reasons other than poor traffic control, such as inclement weather, 
careless driving, defective cars, or poor road conditions. For safety reasons, the vehicle's output has been constantly 
tracked. If an accident occurs, this device sends an immediate warning, with the venue, to the closest hospital through 
the IOT module. The aim of this project is to analyze different parameters and use the IOT method to track the 
calculated parameters. 
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I. INTRODUCTION 
 
In today's world, the Global Positioning System (GPS) is used in a variety of applications. This paper proposes a real-
time vehicle monitoring device based on GPS technologies. Vehicle Tracking via Android App is the name of the 
project. The primary goal of using GSM AND GPRS is to monitor the position of the vehicle on which the system is 
mounted. It will then submit the data to the user's cell phone in the form of latitude and longitude coordinates, which 
will be automatically plotted in the Android app. Initially, the GPS in the system receives data from the satellite and 
stores it in the buffer of the microcontroller. The smartphone consumer must dial the SIM number that is registered in 
the device's GSM module in order to monitor the car. The computer verifies the calling number after it receives the call. 
If the car is validated, an SMS with the vehicle's position is sent to the registered mobile phone. The GSM is turned off 
after the notification is sent, and the GPS is turned back on [1]-[5]. 
 
With almost everybody owning a car these days, burglary is common in parking lots and even traveling insecure areas. 
For public transportation buses, vehicle safety is important. The car has a vehicle detection and locking mechanism 
mounted to map the location and lock the engine generator. Using the Global Positioning System (GPS) and Global 
System Mobile Connectivity, the location of the vehicle was determined (GSM). These devices continuously monitor a 
moving vehicle and provide status updates on request. When a fraud is detected, the liable party sends an SMS to the 
microcontroller, which causes the microcontroller to transmit control signals to the engine motor to quit. To restart the 
vehicle and unlock the lock, an authorized individual must give the password to the controller. This is more safe, 
dependable, and cost-effective. Using GPS and GSM technologies, an innovative form of vehicle monitoring and 
locking mechanisms was used to trace the stolen vehicle. If the car is operated by the driver or registered individuals, 
this mechanism moves it into sleeping mode; otherwise, it switches to active mode [6]-[10]. Persons or remotely 
modified the method of operations. As the robbery is discovered, the perpetrators send SMS to the microcontroller, 
which then sends control signals to the engine motor to quit. Following that, both of the doors were closed. For tracking 
and controlling cars, the Global Positioning System (GPS) is becoming increasingly popular. Many technologies have 
been developed to deliver such facilities, making them more common and necessary than ever. A "GPS car monitoring 
device" is suggested in this article. This device is helpful for fleet owners who want to keep an eye on their workers' 
driving habits, as well as parents who want to keep an eye on their teen drivers. In addition to operating as a 
surveillance mechanism in conjunction with car alarms, this machine may be used in crime prevention as a recovery 
mechanism. This paper's key contribution is that it has two kinds of end-user applications: a desktop application and a 
smartphone interface. As a result, the proposed solution includes a pervasive vehicle monitoring system that can be 
accessed by the driver at any time and from any place. The monitoring services provided by the device involve 
obtaining the current position and ground speed of a specified vehicle as well as any previous date [11]-[15]. It also 
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keeps track of the vehicle by setting speed and geographical limits and sending SMS alerts when the vehicle exceeds 
these limits. Additionally, any of a specified vehicle's motions and stops may be tracked. Everyone has to use a car in 
today's world. Simultaneously, the rate of auto theft is increasingly rising. As a result, protecting cars from vandalism is 
important. Theft in cars may be prevented by utilizing permission for owners and installing anti-theft systems in 
vehicles. Face recognition is used to recognize the approved user in this proposed protection scheme, and the 
comparison is performed using preloaded faces for authorization. Only when the authorized person's face is registered 
by the machine can the vehicle operate. If an unwanted individual or burglary tries to drive the car, the owner will 
receive an SMS/MMS with the vehicle's current position via GSM/GPS modem. In Java, a Principal Component 
Analysis (PCA) algorithm is built for face recognition. The vehicle's current position will be determined using GPS and 
a GSM modem powered by FPGA. The Global System for Mobile (GSM), Global Positioning System (GPS), and 
FPGA was used to provide a real-time surveillance system [16]-[20]. With facial recognition and detection, this 
surveillance device is ideal for real-time tracking in cars, as well as regulating and preventing robbery. 
 

II. EXISTING SYSTEM 
 
A Wireless Framework for Vehicle Accident Detection and Reporting Using Accelerometer was introduced in the 
current system. The accelerometer sensor detects a collision and sends details to the vehicle's GSM system. In the event 
of an injury, the device would transmit an automatic alert via GSM to a pre-programmed number, such as a family 
member's phone number or emergency medical services. They concentrated on warning, and they did so by generating 
a 3-digit 911 request from an in-vehicle TCU to a nearby PSAP. 
 

III. PROPOSED SYSTEM 
 
Temperature sensor, Gyro sensor, brake malfunction detector, Ultrasonic sensor, buzzer, IOT module, and LCD are all 
part of the proposed device. The heat state of the car is monitored using a temperature sensor. The Gyro Sensor is used 
to determine the vehicle's location. As this device senses a braking malfunction, the engine comes to a complete halt. 
This system's sensor data is tracked via IoT, and if an irregular state is observed, a buzzer will sound. The ultrasonic 
sensor detects the barrier and alerts the pilot, as well as activating the buzzer. This device is IOT-enabled, and if an 
accident is observed, the system sends emergency information to the server through the IOT module. 
 
 

 
 

Figure.1.Block diagram of proposed system 
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 ADVANTAGE 
• User friendly 
• Easy to install 
• More efficiency 
• User friendly 

It's crucial to know which COM port your Arduino board uses on your PC while programming it. Go to Start->Devices 
and Printers on Windows and search for the Arduino. Underneath, the COM port will be shown. Alternatively, the alert 
in the lower-left corner of your device indicating that the Arduino has been attached successfully normally indicates the 
COM port it is using. You must first open the IDE before loading any code onto your Arduino board. Double-click the 
Arduino.exe file you previously downloaded. A blank program, referred to as a "sketch," should appear.  
The Blink scenario is the most straightforward way to put every Arduino board to the test. It can be located in the 
Arduino window under File->Examples->Basics->Blink. 
Two critical measures must be completed before the code can be uploaded to the board. 
1. Go to Tools->Board and choose your Arduino from the chart. The Arduino Mega 2560 is the standard board in RBE 
1001, 2001, and 2002, so choose "Arduino Mega 2560 or Mega ADK" from the dropdown. 
2. Go to Tools->Serial Port and choose the contact port, or COM port. 
The COM port that your Arduino board uses should be specified in the dropdown menu if you noted it. If not, the board 
has to be reconnected or it hasn't done mounting. Two buttons are located in the upper left corner of the Arduino 
window: a checkmark to verify the code and a right-facing arrow to upload it. To compile and upload the Blink 
example to your Arduino board, press the correct arrow button. Messages signaling the completion or loss of code 
uploading are shown in the black bar at the bottom of the Arduino pane. If the code has finished uploading to the board, 
you can see a "Completed Successfully" post. If you get an error message instead, make sure you're using the right 
board and COM port in the Tools menu, and double-check the physical links. The LED on your board could blink on 
and off once per second if the upload was good. An LED is prewired to pin 13 on most Arduino boards. When loading 
javascript, it is important that you do not use pins 0 or 1. It is strongly advised that you should not use such pins at any 
time. 
The controller receives Arduino code through a serial port. Older versions have an FTDI chip to handle all USB-related 
issues. Newer versions have a tiny AVR chip that mimics the FTDI chip or a USB-to-serial port installed into the AVR 
microcontroller itself. 
The Proteus Design Framework is a patented software tool suite that is mainly used to automate electronic design. 
Electronic design engineers and technicians use the program to produce schematics and electronic prints for printed 
circuit board production. 
Proteus is a modeling platform for electronic circuit emulation, schematic capture, and PCB design created by 
Labcenter Electronics. It became famous with electronics hobbyists due to its simplicity and user-friendly nature. 
Proteus is often used to simulate digital devices including microcontrollers and microprocessors. It has the ability to 
emulate LEDs, LDRs, and USB communication. Proteus is a modeling and construction software platform for electrical 
and electronic circuit design produced by Labcenter Electronics. It also has a 2D CAD drawing capability. The tagline 
"From idea to execution" is well-deserved. Arduino.cc created the Arduino UNO, an open-source microcontroller board 
built on the Microchip ATmega328P microcontroller. The board has a number of optical and analog input/output (I/O) 
pins that can be used to connect to different extension boards (shields) and other circuits. The board has 14 digital pins 
and 6 analog pins, and it can be programmed using the Arduino IDE (Integrated Development Environment) and a 
USB type B cable. It embraces voltages between 7 and 20 volts and can be operated by a USB cable or an external 9 
volt battery. It's almost comparable to the Arduino Nano and Leonardo microcontrollers. The hardware reference 
architecture is accessible on the Arduino platform under a Creative Commons Attribution Share-Alike 2.5 licence. 
Some models of the hardware have layout and production files accessible as well. In Italian, the word "uno" means 
"only," and it was selected to commemorate the introduction of Arduino Software (IDE) 1.0. The Uno board and 
Arduino Software (IDE) version 1.0 is the reference models of Arduino, which have since been superseded by newer 
updates. The Arduino Uno board is the first of a sequence of USB Arduino boards and serves as the platform's 
reference model. The Arduino Uno's ATmega328 comes pre-programmed with a boot loader that helps you to install 
fresh programming without the need for an external hardware programmer. It uses the initial STK500 protocol to 
connect. The Uno also varies from previous boards in that it does not have the FTDI USB-to-serial driver chip. Instead, 
it employs a USB-to-serial adapter, the Atmega16U2 (Atmega8U2 up to version R2). 
The Arduino project began in Ivrea, Italy, at the Interaction Design Institute Ivrea (IDII). At the time, the students used 
a $100 BASIC Stamp microcontroller, which was a significant outlay for many students. Under the guidance of 
Massimo Banzi and Casey Reas, who are renowned for their work on the Processing language, Hernando Barragán 
developed the development framework Wiring as a Master's thesis project at IDII in 2003. The project's aim was to 
develop easy, low-cost software for non-engineers to build digital projects. The Wiring platform included a printed 
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circuit board with an ATmega168 microcontroller, a Processing-based IDE, and library functions for programming the 
microcontroller. Massimo Banzi, with the help of another IDII student, David Mellis, and David Cuartielles, introduced 
support for the ATmega8 microcontroller to Wiring in 2003. They forked the idea and called it Arduino instead of 
going to focus on Wiring. The FTDI USB-to-serial driver chip and an ATmega168 were used on early Arduino boards. 
The ATmega328P microcontroller and an ATmega16U2 (Atmega8U2 up to version R2) programmed as a USB-to-
serial adapter set the Uno apart from all previous boards. 
A buzzer or beeper is an electronic signaling system that is often used in cars, kitchen appliances such as microwave 
ovens, and game shows. It typically consists of a series of switches or sensors connected to a control device that 
decides whether and which button was pressed, or whether a preset period has elapsed, and normally illuminates a light 
on the relevant button or control panel, as well as sounding an alert in the form of a constant or occasional ticking or 
beeping tone. Originally, this instrument used an electromechanical mechanism that was similar to an electronic bell 
but didn't include the metal gong (which makes the ringing noise). This units were often anchored to a wall or ceiling 
and used it as a sounding board. NodeMCU is a LUA-based collaborative firmware for the Express if ESP8622 Wi-Fi 
SoC, as well as an open source hardware board that, unlike the $3 ESP8266 Wi-Fi modules, contains a CP2102 TTL to 
USB chip for programming and debugging, is breadboard-friendly, and can be driven directly via its micro USB port. 
Espressif Systems produces the NodeMCU, a wifi SOC (system on a chip). It's built around the ESP8266 -12E Wi-Fi 
card. It's a fully engineered processor that's built to fit into a compact box and have complete internet access. It can be 
configured using LUA programming or the Arduino IDE directly via the USB port. We can create a Wifi link and 
identify input/output pins according to your needs using basic programming, just like an Arduino, and transform it into 
a web server, among other things. The Wifi version to an Ethernet module is the NodeMCU. It integrates the functions 
of a Wifi connection point and station with the capabilities of a microcontroller. The NodeMCU is a really good tool 
for WiFi networking because of these features. It may act as an entry point and/or station, as well as host a web server 
and link to the internet to retrieve or upload data. The paper addressed various innovations that have helped to mitigate 
road risks while still presenting current problems with the transportation system. The primary subject of the proposed 
paper was on accident detection and prevention systems. The simulation and prototype effects were thoroughly 
explored. The proposed framework could be useful for traffic officials to monitor collisions using IOT Modules and to 
intervene until they became a nightmare for people's lives. 
 
 

 
Figure.2.Proposed System Output 

 
IV. CONCLUSION 

 
 The paper presented the existing issues of Transportation system and discussed various technologies that have 
contributed to reduce traffic hazards. The proposed paper mainly focused on Accident detection and Prevention system. 
Simulation and Prototype results were discussed in detail. The proposed system could be helpful for traffic officials to 
track the accidents through receiving IOT Module and to aid before leading to any disaster to the lives of people.  
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